Child pages
  • SynchroGrid: Usługa Tracy
Skip to end of metadata
Go to start of metadata

Usługa przeznaczona dla osób związanych z projektowaniem i obsługą Synchrotronu. Usługa polega na udostępnieniu biblioteki i narzędzi Tracy służących do wykonywania obliczeń i symulacji akceleratorów, w szczególności – elektronowych akceleratorów kołowych (synchrotronów).

Biblioteka przeznaczona jest do wykorzystania w programach obliczeniowych napisanych w języku C/C++. Korzystanie z usługi polega na wykorzystaniu procedur i dostarczonych przez Tracy w własnych programach użytkownika napisanych w językach C/C++, które to programy użytkownik po napisaniu kompiluje i linkuje z wymienioną biblioteką, a następnie za pomocą systemu kolejkowego lub innego mechanizmu gridowego wysyła do obliczeń na klastrze.

Aktywowanie usługi

Aby korzystać z usługi, należy mieć założone konto w Portalu PL-Grid i w przypadku korzystania

  • lokalnego w Cyfronecie, należy mieć aktywne usługi: "Dostęp do klastra ZEUS" i  "Tracy"
  • gridowego (aktualnie tylko poprzez system UNICORE), potrzebny jest certyfikat gridowy i aktywna usługa "Globalny dostęp UNICORE" i "Tracy"

Usługi aktywuje się w Portalu Użytkownika, zgodnie z przykładem.

Pierwsze kroki (użycie lokalne)

  1. Zaloguj się na maszynę dostępową (User Unterface - UI):

    ssh -X plglogin@ui.cyfronet.pl
  2. Wejdź do wybranego katalogu np. domowego lub zespołu i pobierz przykładowy zestaw plików tracy-solaris.tgz, np.

    cp $PLG_GROUPS_STORAGE/plggtracy/samples/tracy-solaris.tgz ./
  3. Rozpakuj pobrany plik:

    tar -zxvf tracy-solaris.tgz

     

  4. Dostosuj do swoich wymagań (np. podaj identyfikator grantu, czas obliczeń walltime, liczbę węzłów i procesów, nazwy i lokalizacje plików wejściowych) plik config.sh
  5. Dostosuj do swoich wymagań lub podmień plik solaris-cod.cc
  6. W zależności od potrzeb można również edytować/podmieniać inne pliki potrzebne do wykonania zadania:
    1. local_job_submit.sh - określa on sposób zlecania zadania, wymaga znajomości składni bash
    2. solaris-cod.cc - kod wykonujący obliczenia
    3. solaris-ring.lat - opis struktury symulowanego synchrotronu
    4. Makefile - parametry kompilacji
  7. Zleć zadania:

    ./local_job_submit.sh

     

  8. Po poprawnym wykonaniu z domyślnymi ustawieniami nazw plików, w katalogu bieżącym powinny pojawić się plik solaris-cod.out zawierający wyniki obliczenia orbity elektronów w synchrotronie.

Uwaga: Ścieżka do modułu wygląda następująco: module add libs/tracy

Zaawansowane użycie (zlecenia zadania przez UNICORE Rich Client)

Ogólne informacje na temat zlecania zadań przez UNICORE znajdują się w podręczniku użytkownika: Uruchamianie zadań przez UNICORE

W szczególności, użytkownik powinien posiadać zarejestrowany certyfikat gridowy i otrzymać dostęp do usługi Globalny dostęp UNICORE.

  1. Utwórz keystore zawierający certyfikat i klucz użytkownika (Sekcja Przygotowanie keystore dla usługi Tracy poniżej).
  2. Ściągnij i skonfiguruj klienta UNICORE Rich Client (URC).
  3. Uruchom klienta URC, np.
    1. cd UNICORE-Client-7.0.1
    2. ./UNICORE_Rich_Client
  4. Wskaż scieżkę do keystora/truststora i podaj hasło.

  5. Zaimportuj przykładowe zadanie z katalogu $PLG_GROUPS_STORAGE/plggtracy/samples/tracy-job.zip

    1. File -> Import -> General -> Existing Project into Workspace -> Next
    2. Select Archive File (wskaż scieżkę do tracy-job.zip - standardowego lub własnego przygotowanego na podstawie standardowego)
    3. Finish
  6. Otwórz zadanie Tracy
    1. W oknie Navigator kliknij Script@Target system ...
    2. TracyScript.job (2x)
  7. Dostosuj opis zadania do swoich wymagań (np. podaj identyfikator grantu, czas obliczeń walltime, liczbę węzłów i procesów, nazwy i lokalizacje plików wejściowych)
  8. Zleć zadanie.
  9. Po zakończeniu zadania ściągnij (Download) plik wynikowy i wyświetl go preferowanym edytorem tekstowym lokalnie (na laptopie) lub skojarz w URC pliki 'out' z programem do jego otwierania (np. /usr/bin/nano na UI w ACK)
    1. Window -> Preferences -> General -> Editors -> File Associations

    2. W "File types" "Add" .out a w "Associated editors" "Add" "External programs" i tutaj można wybrać dowolny program (np. /usr/bin/gedit na UI w ACK)

    3. Po dwukrotnym kliknięciu pliku z zadanym rozszerzeniem w URC będzie się on otwierał w wybranym programie (po restarcie URC)

W przypadku używania klienta UCC jest możliwe wykorzystanie bezpośrednio pliku PKCS12 bez potrzeby jego konwersji do formatu JKS: Link

Przygotowanie keystore dla usługi Tracy

 

  1. Zaloguj się na ui.grid.cyfronet.pl i wgraj tam swój certyfikat w formacie P12
  2. Skonwertuj go następująco:
    [plglogin@zeus ~]$ keytool -importkeystore -srcstoretype pkcs12 -srckeystore plglogin.p12 -deststoretype jks -destkeystore plguser.jks
    Enter destination keystore password: [**(moje hasło do p12)**]
    Re-enter new password: [**(moje hasełko do p12)**]
    Enter source keystore password: [**(moje hasełko do p12)**]
    Entry for alias main successfully imported. Import command completed: 1 entries successfully imported, 0 entries failed or cancelled
    [plglogin@zeus ~]$
  3. Skopiuj plik plguser.jks na swój komputer i rozpakuj URC, np. w wersji 7.0.1.
  4. Uruchom URC.
  5. W oknie które się pojawi w "Credentials" wskaż na lokalizację pliku plguser.jks i wpisz [**(moje hasło do p12)**]. Identycznie zrób w zakładce Truststore. Zatwierdź.
  6. Pojawi się okno URC. Kliknij "Workbench".
  7. Skonfiguruj URC.
    W menu: Window -> Download client configuration. Pojawia się okno, w którym wpisz (ze strony https://docs.plgrid.pl/display/PLGDoc/UNICORE+Rich+Client): 
    1. adres: https://unicore.grid.icm.edu.pl:8443/ccm/plgrid-profile-icm.xml
    2. fingerprint: 5A:CF:15:B6:16:24:0E:0F:32:A7:E9:EC:C4:73:1A:C4:96:CA:6F:F6
    3. opcjonalnie Backup
  8. Kliknij OK i otrzymasz dostęp do wszystkich ośrodków poprzez UNICORE w okienku "Grid Browser".

Gdzie szukać dalszych informacji?

Pomoc można uzyskać pisząc na adres helpdesk@plgrid.pl

Opis Tracy można znaleć tutaj: Tracy-user_manual.pdf

 

 

  • No labels