Child pages
  • Synchrogrid: Elegant
Skip to end of metadata
Go to start of metadata

Krótki opis usługi

Usługa przeznaczona dla osób związanych z projektowaniem i obsługą Synchrotronu. Usługa polega na udostępnieniu aplikacji elegant (ELEctron Generation ANd Tracking) w wersji równoległej na klastrze i skonfigurowaniu oprogramowania Matlab do wczytywania  produkowanych przez tą aplikację plików wyjściowych w formacie Self Describing Data Sets (SDDS) i generacji końcowych wyników w formie rysunków.

Aktywowanie usługi

Aby korzystać z usługi należy mieć założone konto w Portalu PL-Grid i w przypadku korzystania

  • lokalnego w Cyfronecie, należy mieć aktywne usługi: "Dostęp do klastra ZEUS" i  "Elegant"
  • gridowego (aktualnie tylko poprzez system UNICORE), potrzebny jest certyfikat gridowy i aktywna usługa "Globalny dostęp UNICORE" i "Elegant"

Usługi aktywuje się w Portalu Użytkownika, zgodnie z przykładem.

Pierwsze kroki (użycie lokalne)

  1. Zaloguj się na maszynę dostępową (User Unterface - UI):

    ssh -X plglogin@ui.cyfronet.pl
  2. Wejdź do wybranego katalogu np. domowego lub zespołu i pobierz przykładowy zestaw plików myElegant.tgz, np.

    cp /mnt/lustre/scratch/groups/plggelegant/scripts/myElegant.tgz . 

    lub

    cp $PLG_GROUPS_STORAGE/plggelegant/scripts/myElegant.tgz .
  3. Rozpakuj pobrany plik i wejdź do niego

    tar -zxvf myElegant.tgz
    cd myElegant
  4. Dostosuj do swoich wymagań (np. podaj identyfikator grantu, czas obliczeń walltime, liczbę węzłów i procesów, nazwy i lokalizacje plików wejściowych) plik config.sh
  5. W zależności od potrzeb można również edytować inne pliki potrzebne do wykonania zadania:
    1. local_job_submit.sh
    2. frequencyMapFast.ele
    3. ring523new.lte
    4. skrypty Matlabowe Matlab/PlotFMAnu.m i Matlab/PlotFMAxy.m
  6. Zleć zadania:

    ./local_job_submit.sh PlotFMAnu:PlotFMAxy
  7. Po poprawnym wykonaniu z domyślnymi ustawieniami nazw plików, w katalogu bieżącym powinny pojawić się pliki Bare523.fma, PlotFMAnu.jpg, PlotFMAxy.jpg
  8. Pliki można je wyświetlić poleceniem: qiv PlotFMAxy.jpg (jeżeli przy logowaniu na UI użyto opcji X służącej do przekierowania X-ów).
Zachęcamy do obejrzenia filmu instruktażowego z użycia usługi w sposób lokalny (zlecanie zadań z UI).

Zaawansowane użycie (zlecenia zadania przez UNICORE Rich Client)

Ogólne informacje na temat zlecania zadań przez UNICORE znajdują się w podręczniku użytkownika: Uruchamianie zadań przez UNICORE

W szczególności, użytkownik powinien posiadać zarejestrowany certyfikat gridowy i otrzymać dostęp do usługi Globalny dostęp UNICORE.

  1. Utwórz keystore zawierający certyfikat i klucz użytkownika (Sekcja Przygotowanie keystore dla usługi Elegant poniżej).
  2. Ściągnij i skonfiguruj klienta UNICORE Rich Client (URC).
  3. Uruchom klienta URC, np.
    1. cd UNICORE-Client-6.4.3
    2. ./UNICORE_Rich_Client
  4. Zaimportuj przykładową kaskadę zadań (workflow) z katalogu myElegant/Elegant-URC-workflow.tar.gz
    1. File -> Import -> General -> Existing Project into Workspace -> Next
    2. Select Archive File (wskaż scieżkę do Elegant-URC-workflow.tar.gz)
    3. Finish
  5. Otwórz workflow Elegant
    1. File -> Open File -> (wskaż scieżkę do UNICORE*/workspace/Elegant/Elegant.flow)
    2. OK
  6. Dostosuj do swoich wymagań (np. podaj identyfikator grantu, czas obliczeń walltime, liczbę węzłów i procesów, nazwy i lokalizacje plików wejściowych)
  7. Zleć workflow
  8. Po zakończeniu zadania ściągnij (Download) plik wynikowy i wyświetl go preferowanym programem do grafiki lokalnie (na laptopie) lub skojarz w URC pliki jpg z programem do ich otwierania (np. /usr/bin/qiv na UI w ACK)
    1. Window -> Preferences -> General -> Editors -> File Associations

    2. W "File types" "Add" .jpg a w "Associated editors" "Add" "External programs" i tutaj można wybrać dowolny program (np. /usr/bin/qiv na UI w ACK)

    3. Po 2x kliknięciu pliku z zadanym rozszerzeniem w URC bedzie sie on otwierał w wybranym programie (po restarcie URC)

Do obejrzenia jest przykładowy film z użycia usługi w sposób gridowy (zlecanie zadań przy pomocy UNICORE Rich Client). 

W przypadku używania klienta UCC jest możliwe wykorzystanie bezpośrednio pliku PKCS12 bez potrzeby jego konwersji do formatu JKS: Link

Przygotowanie keystore dla usługi Elegant

Skopiuj swoj certyfikat gridowy (np. SimpleCA otrzymany w Portalu) na swoje konto na maszynie z której planujesz uruchamiać zadania (np. laptop).

Przygotowanie keystora na podstawie certyfikatu Simple CA otrzymanego z portalu:

Skonwertuj *.p12 do *.jks w sposób pełny, tzn. ze zmianą hasła ('haslo z p12' w przykładzie) na nowe (w przykładzie 'haslo123') do keystore'a podczas konwersji i potem dodatkowo zmianą hasła klucza znajdującego się w pliku .jks (nie może istnieć już taki plik):

$rm plguser.jks
$keytool -importkeystore -srcstoretype pkcs12 -srckeystore plguser.p12 -deststoretype jks -destkeystore plguser.jks

Enter destination keystore password: [haslo123]
Re-enter new password: [haslo123]
Enter source keystore password: [haslo do p12]
Entry for alias main successfully imported.
Import command completed:  1 entries successfully imported, 0 entries failed or cancelled

$keytool -keypasswd -keystore plguser.jks -alias main
Enter keystore password: [haslo123]
Enter key password for <main> [haslo z p12]
New key password for <main>: [haslo123]
Re-enter new key password for <main>: [haslo123]

Gdzie szukać dalszych informacji?

Dokumentacja oprogramowania elegant: http://www.aps.anl.gov/Accelerator_Systems_Division/Accelerator_Operations_Physics/manuals/elegant_latest/elegant.pdf

Pomoc można uzyskać pisząc na adres helpdesk@plgrid.pl


  • No labels